Skip to main content

Troubleshooting the Teamcenter Rich Client Integration

Troubleshooting procedures and log configuration for the CoLab integration for Teamcenter.

Client and server logs

The CoLab integration for Teamcenter generates both server-side and client-side logs. The client-side integration logs are included in the existing Teamcenter RAC logs, and the server-side logs are included in the existing Teamcenter server logs.

Configure client logging

To enable logging for the Rich Client CoLab integration on Teamcenter 13 or 14:

  • Navigate to the Teamcenter installation location.

  • Locate the file named log4j2.xml under the installation directory in ./portal/plugins/[Teamcenter Configuration Name].

  • Edit log4j2.xml and add the following configuration to the <Loggers> section:

<Logger name="com.colab.sharewithcolab" level="DEBUG" additivity="false">
<AppenderRef ref="TcLoggerConsoleAppender"/>
<AppenderRef ref="TcLoggerFileAppender"/>
</Logger>

Note: DEBUG is recommended for testing and debugging issues. It includes warnings, errors, and verbose diagnostic details.

  • Save the log4j2.xml file.

Locate client and server logs

To locate the Rich Client and server logs:

  1. With the Teamcenter rich client open, navigate to Help > About.

  2. Note the paths shown for the Rich Client Log File and Server Log File.

  3. Open the appropriate file path from step 2.

Preserve files for troubleshooting

If the Teamcenter integration does not behave as expected, you can configure it to preserve temporary files generated during an upload.

These files can provide additional information to CoLab Support when troubleshooting issues such as failed or incomplete uploads.

To preserve these files:

  1. Launch the Teamcenter Rich Client.

  2. Go to Edit → Options → Search → Search on Keywords.

  3. Search for TC_COLAB_DEBUG.

  4. Set the TC_COLAB_DEBUG preference to one of the following values:

    • both — Preserve the raw JSON files and model files.

    • json — Preserve only the raw JSON files and remove the model files.

    • none or no value — Remove both the JSON files and model files.

Configure the temporary directory

By default, preserved files are stored in %TEMP% on Windows or $TEMP on Linux.

To use a different location, set the TC_COLAB_TEMPDIR environment variable to the desired directory.

Did this answer your question?